$re = '/(?i)(<a)(?=((?:[^>"\']|"[^"]*"|\'[^\']*\')*?\s)(href\s*=\s*([\'"])\/mycms\/~\/link\.aspx\?_id=([a-f0-9]{32})&_z=z\4)((?:"[\S\s]*?"|\'[\S\s]*?\'|[^>]*?)+>))\s+(?:"[\S\s]*?"|\'[\S\s]*?\'|[^>]*?)+>/';
$str = '<a hello world href="/mycms/~/link.aspx?_id=D9423CEFED254610A5DC6B096A297E17&_z=z" class>
...
</a>
<img hello world src="/mycms/~/media/B1FB91AC357347BD84913D56B8791D03.ashx" alt="" width="690" height="202" />
';
$subst = "$1$2href='NEWID:key{$5}'$6";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;