#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^(?!.*[@\.\_\d])[A-Za-z\x{00C0}-\x{00FF}][A-Za-z\x{00C0}-\x{00FF}\'\-]+([\ A-Za-z\x{00C0}-\x{00FF}][A-Za-z\x{00C0}-\x{00FF}\'\-]+)*"
Local $sString = "Pedro" & @CRLF & _
"Juan Andrés" & @CRLF & _
"Angel María España" & @CRLF & _
"Peter Thorne-Smidth" & @CRLF & _
"Flor@s" & @CRLF & _
"" & @CRLF & _
"- it doesn't match if first comes a space!" & @CRLF & _
"- numbers @ _ . and oder special chars are not allowed"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")