$re = '/^(?:.*\.)?(?:microsoft|bing)\.(?:de|com)$/m';
$str = 'something.microsoft.com
something.bing.de
somethingmicrosoft.com
something-bing.com
microsoft.com
bing.de';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);