using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:https?:\/\/)?(?:\w+\.)*website\.com(?!\/team|\/forum)\S*";
string input = @"https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/
https://www2.website.com
http://www2.website.com/
https://www.website.com/
http://www.website.com/
https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search
https://www2.website.com/team/
https://www2.website.com/team
https://www2.website.com/forum/index.php
website.com/team
website.com/forum
http://website.com/team
https://website.com/forum
https://website.com/forum/test
https://www.website.com
http://website.com
website.com/test
website.com
website.com/
http://website.com
https://website.com
https://www.website.com
http://website.com
test http://website.com test https://website.com/forum or website.com/test
https://www.test.com
https://sub.website.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}