#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[\w]+\s*)*(\d*-\d*\s*[A-Z0-9]+\s*\([a-z]\)\s*([A-Z]*\s*\d*))\s*"
Local $sString = "Utorak 10-13 RBP (v) JAG 2 14-16 A2 (v) BIM" & @CRLF & _
"Sreda 9-12 PPJ (v) 718 12-14 RBP (p) 821 14-16 PPJ (p) 718" & @CRLF & _
"Cetvrtak 11-14 RG (v) BIM 14-16 RG (p) BIM "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")