import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[\\w]+\\s*)*(\\d*-\\d*\\s*[A-Z0-9]+\\s*\\([a-z]\\)\\s*([A-Z]*\\s*\\d*))\\s*";
final String string = "Utorak 10-13 RBP (v) JAG 2 14-16 A2 (v) BIM\n"
+ "Sreda 9-12 PPJ (v) 718 12-14 RBP (p) 821 14-16 PPJ (p) 718\n"
+ "Cetvrtak 11-14 RG (v) BIM 14-16 RG (p) BIM ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}