use strict;
my $str = 'Utorak 10-13 RBP (v) JAG 2 14-16 A2 (v) BIM
Sreda 9-12 PPJ (v) 718 12-14 RBP (p) 821 14-16 PPJ (p) 718
Cetvrtak 11-14 RG (v) BIM 14-16 RG (p) BIM ';
my $regex = qr/(^[\w]+\s*)*(\d*-\d*\s*[A-Z0-9]+\s*\([a-z]\)\s*([A-Z]*\s*\d*))\s*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}