import Foundation
let pattern = #"(^[\w]+\s*)*(\d*-\d*\s*[A-Z0-9]+\s*\([a-z]\)\s*([A-Z]*\s*\d*))\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Utorak 10-13 RBP (v) JAG 2 14-16 A2 (v) BIM
Sreda 9-12 PPJ (v) 718 12-14 RBP (p) 821 14-16 PPJ (p) 718
Cetvrtak 11-14 RG (v) BIM 14-16 RG (p) BIM
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)