#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:A|A |AA F|M)\d+(?:-\d+|\+)"
Local $sString = "A25-54 plus affinities targeting,Demo (AA F21-54)," & @CRLF & _
"A25-49 Artist Affinity Targeting,M21-49 plus,plus plus A 21+ targeting"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")