import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:A|A |AA F|M)\\d+(?:-\\d+|\\+)";
final String string = "A25-54 plus affinities targeting,Demo (AA F21-54),\n"
+ "A25-49 Artist Affinity Targeting,M21-49 plus,plus plus A 21+ targeting";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}