// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)from:\s*"+\s*[a-zA-Z]*+\s*"\s*,\s*to:\s*"\s*[a-zA-Z]*\s*"\s*,\s*content:\s*"\s*[a-zA-Z]*\s*"\s*"#).unwrap();
let string = "from: \"Sender\", to: \"Receiver\", content: \"Payload\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}