import re
regex = re.compile(r"( 's| 'd)|[[:lower:]](\.|\!|\?) ?\"?[[:lower:]]|(\w|\"),\"?\w|( |^)\"?(i|\"|'|,|\!|\?|\.)(\s|\")|_|(“|”)|\|", flags=re.MULTILINE)
test_str = ("| 12:30pm |\n"
"Jeff 's friend said he 'd let us know when it 's done. the next day he called.\"it's done.\",he said,Obviously lying.\n"
"i was not happy with the result. \" Do it again !\" i just could _not_ believe how _bad_ it was .\n"
"“What's wong with it?”")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")