use strict;
my $str = ' GS is the main company of Dow Jones <TKR> is the main company of Dow Jones
1 Once again Visa surprises all Once again Visa surprises all
2 Johnson & Johnson\'s vaccine is the best one Johnson & Johnson\'s vaccine is the best one';
my $regex = qr/\b(?:The(?:\s+Travelers)?(?:\s+Companies)?|Johnson(?:\s+\&)?(?:\s+Johnson)?|JPMorgan(?:\s+Chase)?|Goldman(?:\s+Sachs)?|Visa(?:\s+Inc\.)?|Amgen)(?!\w)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}