#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[12]\d|3[01]|[1-9]),?\b)+$"
Local $sString = "1,22,31" & @CRLF & _
"A" & @CRLF & _
"31,33,33" & @CRLF & _
"2,," & @CRLF & _
"1,2.,3%" & @CRLF & _
"0,1,2,3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")