using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[12]\d|3[01]|[1-9]),?\b)+$";
string input = @"1,22,31
A
31,33,33
2,,
1,2.,3%
0,1,2,3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}