package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9][a-zA-Z0-9][a-zA-Z0-9]-[a-zA-Z0-9][a-zA-Z0-9][a-zA-Z0-9]-.+$`)
var str = `UEF-KH1-errttz
B4A-F6F-öweiuj
ABC-DEF-17-021
AB-DEF-17-021
ABC-DEF-1
ABC-DEF
ABC-DEF-
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}