use strict;
my $str = 'At_5.2000_displacement
At_-6.4000_displacement
At_-0.4000_displacement
At_0.4000_displacement
At_2nd_-4.3000_displacement
At_2nd_2.2000_displacement';
my $regex = qr/At_[-0-9.]*_displacement/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}