# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\bfox\b)"
test_str = ("the quick brown fox // matches\n"
"fox jumps over the lazy dog // matches\n"
"quick brown fox jumps over // matches\n\n\n"
"the quick brownfox // does not match\n"
"foxjumps over the lazy dog // does not match\n"
"quick brownfox jumps over // does not match\n"
"quick brown foxjumps over // does not match\n"
"quick brownfoxjumps over // does not match")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.