import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(.+?),\"(.+?)\",\"([^,]+)\",";
final String string = "Title,Des,Description,价格,原价,SKU,库存,产品类别,供应商,产品系列,SEO标题,SEO描述\n"
+ "Pendientes Olivia,\"El verde es uno de los colores más nobles en la joyería alta, este par de hermosos pendientes con un cristal de color verde esmeralda resalta tu elegancia, imprescindible para poder lucir tus joyas\",\"Pendientes de Plata de Ley 925\n"
+ "Acabado: Baño en Oro de 14k\n"
+ "Alto: 2.6cm\n"
+ "Sistema de cierre: Tuerca tradicional\n"
+ "Peso: 2.1g\",14.95,,PE10004AU,100,Pendientes,Vltana,Pendientes,Comprar pendientes Olivia en Vltana,Pendientes Olivia Descubre nuestro modelo de pendientes de plata de diseño y calidad. Consigue la Última Novedad de Vltana. Compra de forma segura y hazte con este Best Seller. Envíos Gratis desde 30€.\n"
+ "Pendientes Bagan,\"Un interior de color blanco perlado y un marco irregular dorado, se han creado una combinación inesperada. Su textura suave y fina presenta un estilo clásico y elegante. La sencillez y su naturaleza acaban siendo una pieza irremplazable.\",\"Pendientes de Plata de Ley 925\n"
+ "Acabado: Baño en Oro de 18k\n"
+ "Largo: 1.3cm\n"
+ "Sistema de cierre: Tuerca tradicional\n"
+ "Peso: 0.9g\",19.95,,PE10005AU,50,Pendientes,Vltana,Pendientes,Comprar pendientes Bagan en Vltana,Pendientes Bagan Descubre nuestro modelo de pendientes de plata de diseño y calidad. Consigue la Última Novedad de Vltana. Compra de forma segura y hazte con este Best Seller. Envíos Gratis desde 30€.";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}