# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:\/[A-Za-z0-9-]+)+)?(\/tag\/[A-Za-z0-9-%]+)+(\/.*)?"
test_str = ("http://example.com/cat1/subcat3/subcat4/tag/this%20is%20page/asdasda?start=130/asdasdasd\n"
"http://example.com/cat1/subcat3/subcat4/tag/this%20is%20pageasdasd\n"
"example.it/news/tag/this%is%20n%page?adsadsadasd\n"
"http://example.com/tag/thispage/asdasdasd.-?asds=\n"
"http://example.com/tag/this%20is%20page/asdasd\n"
"http://example.com/tag/this\n")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.