package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^#]*#){2}([^#]*)`)
var str = `3#White House, District Of Columbia, United States#US#USDC#DC001#38.8951#-77.0364#531871#382`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}