package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^m]>`)
var str = `<test@gmail.com>
>Lorem ipsum dolor sit amet,<test@gmail.com> consectetur
>adipiscing elit. Integer nec >
>odio. Praesent libero. Sed cursus ante dapibus diam. Sed nisi. Nulla
>quis sem at nibh elementum imperdiet.Duis sagittis ipsum. Praesent
>mauris. Fusce nec tellus sed augue semper porta. Mauris massa.
>Vestibulum lacinia arcu eget nulla. Class aptent taciti sociosqu.
<test@gmail.com>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}