// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Za-z]+)(?:\.([A-Za-z]+))?(?:\.([A-Za-z]+))?\.\d+@[^\s@]+").unwrap();
let string = "firstname.1234@email.com
firstname.lastname.1234@email.com
firstname.middlename.lastname.1234@email.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}