#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?filename="?\K[^";]+"
Local $sString = "'attachment;filename="unnamed.jpg";filename*=UTF-8\'\'unnamed.jpg\'" & @CRLF & _
"'attachment;filename=unnamed.jpg;filename*=UTF-8\'\'unnamed.jpg\'" & @CRLF & _
"'attachment;filename=unnamed.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")