re = /^.*?filename="?\K[^";]+/m
str = '\'attachment;filename="unnamed.jpg";filename*=UTF-8\\\'\\\'unnamed.jpg\\\'
\'attachment;filename=unnamed.jpg;filename*=UTF-8\\\'\\\'unnamed.jpg\\\'
\'attachment;filename=unnamed.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end