#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)((?<=time:.).*?(?=;))|((?<=A:.).*?(?=;))|((?<=B:.\().*?(?=\)))|((?<=C:.\().*?(?=\)))|((?<=D\().*?(?=\)))|((?<=E:.\().*?(?=\)))"
Local $sString = "time: 2017-12-24 13:13:34 +0000; A: 61792; B: (" & @CRLF & _
"60328," & @CRLF & _
"60344," & @CRLF & _
"60344," & @CRLF & _
"60344" & @CRLF & _
"); C: (" & @CRLF & _
""-3672"," & @CRLF & _
""-3656"," & @CRLF & _
"1547," & @CRLF & _
"1578" & @CRLF & _
"); D(" & @CRLF & _
"1500," & @CRLF & _
"1484," & @CRLF & _
"1500," & @CRLF & _
"); E: (" & @CRLF & _
"313," & @CRLF & _
"328" & @CRLF & _
")" & @CRLF & _
"time: 2017-12-25 13:13:35 +0000; A: 6134; B: (" & @CRLF & _
"628," & @CRLF & _
"60374," & @CRLF & _
"6044" & @CRLF & _
"); C: (" & @CRLF & _
""-72"," & @CRLF & _
""6"," & @CRLF & _
"157," & @CRLF & _
"157" & @CRLF & _
"); D(" & @CRLF & _
"1700," & @CRLF & _
"1654," & @CRLF & _
"1580," & @CRLF & _
"); E: (" & @CRLF & _
"3103," & @CRLF & _
"3208" & @CRLF & _
")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")