$re = '/[^\(\):]*:\s*(\w*)/';
$str = 'savedPosition: comp;
CURLSCHET.NREC (\'qwertyuiop\'): noprotect;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);