import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?<=\\s)\\w*(?=\\-.*)";
final String string = "This is [INFO] 29 Jun 2018 06:06:49,620 SYSLOG->|datetime:20180629060649618+0000|\n"
+ " my first sentence. \n"
+ " This is my [second] sentence.(?<=\\[).*?(?=\\].*)";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}