$re = '/(?s)(?<=\s)\w*(?=\-.*)/s';
$str = 'This is [INFO] 29 Jun 2018 06:06:49,620 SYSLOG->|datetime:20180629060649618+0000|
my first sentence.
This is my [second] sentence.(?<=\\[).*?(?=\\].*)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);