use strict;
my $str = '፻this test works፻
፻this test does not work፻
this is a line that stays unchanged
this is a line that stays unchanged፻
፻this is a line that stays unchanged';
my $regex = qr/(?<=^፻.+)\b(\w+)(?=.*፻$)፻?/mp;
my $subst = '፻$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";