# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([A-Z0-9]{4})"
test_str = (" ; Message Number\n"
" ; | Time Offset (ms)\n"
" ; | | Type\n"
" ; | | | ID (hex)\n"
" ; | | | | Data Length\n"
" ; | | | | | Data Bytes (hex) ...\n"
" ; | | | | | |\n"
" ;---+-- ----+---- --+-- ----+--- + -+ -- -- -- -- -- -- --\n"
" 1) 2.0 Rx 0400 8 01 5A 01 57 01 D2 A6 02 \n"
" 2) 8.6 Rx 0500 8 02 C1 02 C9 02 BE 02 C2 \n"
" 3) 36.2 Rx 0401 8 01 58 01 59 01 01 01 01 \n"
" 4) 41.7 Rx 01C4 8 27 9C 64 8C 00 03 E8 08 \n"
" 5) 43.1 Rx 0501 8 02 C0 02 C1 02 C6 02 C0 \n"
" 6) 62.7 Rx 01C2 8 27 9C 60 90 00 0F 04 08 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.