package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)I select (.*) and generate Print Statement for \"(.*?)\" with \"(.*?)\"?$`)
var str = `I select PDFPrinter and generate Print Statement for "Deposit Account" with "RandomCustomer"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}