// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)I select (.*) and generate Print Statement for \"(.*?)\" with \"(.*?)\"?$"#).unwrap();
let string = "I select PDFPrinter and generate Print Statement for \"Deposit Account\" with \"RandomCustomer\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}