re = /^(?=.*?[a-z])(?=.*?[A-Z])(?=.*?\d)[A-Za-z\d@$!%*#?&]{6,}$/m
str = 'yoU9&09
turn
FFFFFFFF
pa55W0rd
oeoj90I'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end