# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?Stack){3}\K/\n/gi;t' <<< "Stack is a linear data structure stack follows a particular order in stack the operations are performed"