use strict;
my $str = 'Stack is a linear data structure stack follows a particular order in stack the operations are performed';
my $regex = qr/(.*?Stack){3}\K/ip;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";