import re
regex = re.compile(r"M\D*[\d\.]+\s*[a-zA-Z]*\s*[\d\.]+", flags=re.MULTILINE)
test_str = ("M between 1 and 12\n"
"M abcdeghi 12\n"
"Mdasklfasdlj123\n"
"M 1 3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")