import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "MLFTLGH[a-zA-Z0-9]{8}";
final String string = "Hi,\n\n"
+ "I have a requirement where I have to extract the required string like \"MLFTLGH105456IV!\" from a total string.\n\n"
+ "The required string is fixed in length and will always start with MLFTLGH followed by 8 alpha numerical characters in random with no space in between as in above format but can appear anywhere within the total string like at the beginning of total string, middle of total string or at the last of total string.\n\n"
+ "Some more required string examples - MLFTLGH10545001, MLFTLGH105456GH, MLFTLGH1054565D, MLFTLGH100542TH\n\n"
+ " \n\n"
+ "Please suggest how to extract the required string.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}