package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^BusinessServices\/(.*)\/(.*)\/Interface\/(((.*)(_EMSReceiver|_PushFilesPoller))|(JobScheduler|LoadSpainRoutingTableData|PurgeDirectories))\.process`)
var str = `BusinessServices/V001/Common/Interface/JMSFileSender.process
BusinessServices/V001/Common/Interface/JobScheduler.process
BusinessServices/V001/Common/Interface/LoadSpainRoutingTableData.process
BusinessServices/V001/Common/Interface/Logys_Impl.process
BusinessServices/V001/Common/Interface/PurgeDirectories.process
BusinessServices/V001/D365/Interface/D365_EMSReceiver.process
BusinessServices/V001/SOURCE/Interface/SOURCE_PushFilesPoller.process
BusinessServices/V001/TARGET/Interface/TARGET_EMSReceiver.process`
var substitution = "Service=$1-$2, Operation=$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}