#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{3}.*|^\(.*|^1\s.*)"
Local $sString = "415-555-1234" & @CRLF & _
"650-555-2345" & @CRLF & _
"(416)555-3456" & @CRLF & _
"202 555 4567" & @CRLF & _
"4035555678" & @CRLF & _
"1 416 555 9292"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")