package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{3}.*|^\(.*|^1\s.*)`)
var str = `415-555-1234
650-555-2345
(416)555-3456
202 555 4567
4035555678
1 416 555 9292`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}