// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{3}.*|^\(.*|^1\s.*)").unwrap();
let string = "415-555-1234
650-555-2345
(416)555-3456
202 555 4567
4035555678
1 416 555 9292";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}