#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^(?P<amount>\d+)" & @CRLF & _
"(?:(?!^$)[\s\S])+" & @CRLF & _
"\(medium\)"
Local $sString = "4211 dogs ate 2 pounds" & @CRLF & _
" chris (large)" & @CRLF & _
"" & @CRLF & _
"3454 dogs ate 8 pounds" & @CRLF & _
" john (medium)" & @CRLF & _
" alex (small)" & @CRLF & _
"" & @CRLF & _
"4211 dogs ate 2 pounds" & @CRLF & _
" morgan (small)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")