(?m)applies the following effective flags to the remainder of the pattern: gm m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string
^start of line
Non-Capturing Group(?: +|\t+) the literal (3210 / 408 / 2016)
+the literal (3210 / 408 / 2016) , repeated at least once
\t+a tab character (ASCII 9), repeated at least once
\+the literal + (4310 / 538 / 2B16)
*the literal (3210 / 408 / 2016) , repeated any number of times
Non-Capturing Group(?:VAR|CONST) VARthe literal text VAR (case sensitive) CONSTthe literal text CONST (case sensitive) *the literal (3210 / 408 / 2016) , repeated any number of times
\w+any word character, repeated at least once
*the literal (3210 / 408 / 2016) , repeated any number of times
=the literal = (6110 / 758 / 3D16)
.*any character (except for line terminators), repeated any number of times
Non-Capturing Group(?:\R^(?> +|\t+)[^+\s].*)* *repeats the group contents below any number of times:
\Ra newline sequence
^start of line
the literal (3210 / 408 / 2016)
+the literal (3210 / 408 / 2016) , repeated at least once
\t+a tab character (ASCII 9), repeated at least once
Negated Character Class[^+\s] +the literal + (4310 / 538 / 2B16)
\sany whitespace character
.*any character (except for line terminators), repeated any number of times
g modifier: global. Finds all matches instead of stopping after the first