import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[\\d+(,\\s?\\d+|\\d*-\\d+)*\\])";
final String string = "[3,33-24,7]\n"
+ "[3-34]\n"
+ "[1,3-5]\n"
+ "[1]\n"
+ "[1,2]\n"
+ "[1, 2, 3]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}