$re = '/\{((?:[^{}]|(?R))*)\}/m';
$str = 'Eu sou uma string {dentro de uma string {dentro de outra} }
String {com {vários {níveis {de } chaves}} aninhadas}.
String {com mais {de} um} trecho {com {chaves}}
String com {chaves {desbalanceadas}
Chaves {} vazias
Apenas {um par de} chaves
Somente abre { chaves.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);