# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?)PLC\.com(?:\\/\ben\b)?(.*)/$1LTD.com$2/gm;t' <<< "https://www.mycompanyPLC.com/en/lorem/ipsum/whatever
https://www.mycompanyPLC.com/lorem/ipsum/whatever
http://www.mycompanyPLC.com/random/query/url
http://www.mycompanyPLC.com/en/random/query/url
ftp://www.mycompanyPLC.com/en/random/query/url
"