// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?)PLC\.com(?:\/\ben\b)?(.*)").unwrap();
let string = "https://www.mycompanyPLC.com/en/lorem/ipsum/whatever
https://www.mycompanyPLC.com/lorem/ipsum/whatever
http://www.mycompanyPLC.com/random/query/url
http://www.mycompanyPLC.com/en/random/query/url
ftp://www.mycompanyPLC.com/en/random/query/url
";
let substitution = "$1LTD.com$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}