# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?:\£(?:[1-9]\d{0,2}(?:,\d{3})*|[0-9]+)?(?:\.\d{1,2})?|[^\n.])+)\.(.*)/\n/gm;t' <<< "This string should not split as the only periods that appear are here £19.99 and also here.
This string should split right here. As the period is not part of a price or at the end of the string.
There is a price in this string £19.99, but it should only split at this point. As I want it to ignore periods in a price. "