#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(\s*[0-9]+\s*),(\s*[0-9]+\s*)\]\s*(>=|<=|==|>|<)\s*([0-9]+)\s*(\|\||\&\&)*"
Local $sString = "[1,2]==3 || [1,110] >= 2 && [1,200] > 3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")